Picoscope 5204 not found. Windows 7, rev 6.14.69

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
Elithion
Newbie
Posts: 0
Joined: Thu Jun 03, 2010 3:40 pm

Picoscope 5204 not found. Windows 7, rev 6.14.69

Post by Elithion »

My Picoscope 5204 works fine on a Windows 7 computer with rev 6.14.61 software.

On a different Windows 7 computer with rev 6.14.69 software, the oscilloscope software does not see the picoscope.

The driver was installed successfully and the Device Manager lists the picoscope. When I connect the USB cable, the oscilloscope software shows an "Opening devices" dialog for 2 seconds. But when I open the Connect Device dialog, the picoscope is not listed.

I was hoping to try rev 6.14.61 software but its download page is 404. I do not intend to upgrade the first windows computer to 6.14.69 for fear that doing so will break it as well.

Gerry
PICO STAFF
PICO STAFF
Posts: 1144
Joined: Mon Aug 11, 2014 11:14 am

Re: Picoscope 5204 not found. Windows 7, rev 6.14.69

Post by Gerry »

This has been reported to our help desk and is being answered there.
Gerry
Technical Specialist

Elithion
Newbie
Posts: 0
Joined: Thu Jun 03, 2010 3:40 pm

Re: Picoscope 5204 not found. Windows 7, rev 6.14.69

Post by Elithion »

Update, in case it may help others:

Tech support got back to me and told me to update Windows 7. I did, but that made no difference.
Tech support also gave me a link for rev 6.14.61 software. I installed it, and that worked.

Thank you for your help, Picotech people!

Post Reply